Сообщение об ошибке «Невозможно установить или запустить приложение. Для приложения требуется стандартная версия 7.0.3300.0 в GAC.

Получается, что файлы .NET clickonce были скопированы в C:\Program Files\Microsoft.NET\Primary Interop Assemblies\. Однако dot-net они никогда не регистрировались dot-net в GAC.

В итоге я вручную перетащил dot-net файлы из C:\Program Files\Microsoft.NET\Primary Interop Assemblies в C:\windows\assembly, и приложение .net-framework работало на этой проблемной .net-framework машине. Вы также можете сделать .net это программно с помощью dotnet Gacutil.

Похоже, что что-то случилось clickonce с .NET во время установки, но .net-framework это, похоже, решает проблему. Надеюсь, это .net-framework поможет кому-то другому!

.net

clickonce

gac

stdole

2022-08-17T15:35:46+00:00